Home Forums Plugin Support AffiliateWP MLM MLM not properly giving credit for subscription payments

35 replies, 2 voices Last updated by lewtam 4 months, 2 weeks ago
    • lewtam
      Participant
      @lewtam
      #12415

      Hey Christian,

      I have a 3 level setup

      On the initial purchase all commissions track correctly but on the recurring subscription commissions are only awarded to the Parent affiliate and doesn’t flow up the levels:

      Ex.

      INITIAL COMMISSION

      Level 0 gets 40%
      Level 1 gets 20%
      Level 2 gets 20%

      RECURRING SUBSCRIPTION (this happens when level 2’s customer recurring payment is created)

      Level 0 gets 0%
      Level 1 gets 0%
      Level 2 gets 20%

      I’m thinking maybe settings issue but not quite sure which setting, Maybe in the Lifetime Commissions?

      Attachments:
      You must be logged in to view attached files.
    • lewtam
      Participant
      @lewtam
      #12434

      Any ideas?

    • Christian Freeman
      Participant
      @christianf
      #12438

      Hi there,

      First, I want to ensure we are on the same page here. Are you saying that it is creating the Indirect Commissions for the Upline on the Recurring Payment, and the only issue is that the Commission Rate is incorrect?

      Or is it just not creating the Indirect Commission at all when the Recurring Payment is made?

    • lewtam
      Participant
      @lewtam
      #12440

      No. It is not creating recurring commissions. It seems to create for the direct upline but none are being created for the indirect upline. So when level 2’s customer makes a recurring payment, level 2 gets their correct percentage but level 1 & level 0 are not receiving anything.

    • Christian Freeman
      Participant
      @christianf
      #12455

      I’ll review the code in MLM to see why this could be happening.

      You are using the MemberPress integration for your subscriptions, correct?

    • lewtam
      Participant
      @lewtam
      #12457

      Yes MemberPress.

    • lewtam
      Participant
      @lewtam
      #12475

      Able to pinpoint the bug?

    • Christian Freeman
      Participant
      @christianf
      #12476

      You know what, this could just be an order-of-activation issue.

      The AffiliateWP Team just updated Recurring Referrals on your site, correct? This would mean that Recurring Referrals was activated AFTER MLM. Recurring Referrals needs to be activated beforehand, so that it can create the Direct Referral for the recurring payments, then MLM taps into it and generates the Indirect Referrals.

      Try deactivating MLM and Recurring Referrals, then activate Recurring Referrals first, and MLM after.

      Let me know how this works for you.

    • lewtam
      Participant
      @lewtam
      #12477

      Mannnn I didn’t think of that… Let me do that now! I’ll guve you an update as soon as I’ve had a chance to run a few test.

    • lewtam
      Participant
      @lewtam
      #12478

      Unfortunately, that didn’t fix it. Any other ideas?

    • Christian Freeman
      Participant
      @christianf
      #12480

      Hmmmm, I’m going to have to login to your site to investigate further.

      Can you please provide admin-level logins for you site? And be sure to mark your reply as Private.

    • lewtam
      Participant
      @lewtam
      #12481
      This reply has been marked as private.
    • lewtam
      Participant
      @lewtam
      #12482
      This reply has been marked as private.
    • Christian Freeman
      Participant
      @christianf
      #12483

      Thanks, I’ll take a look at it and follow up with you soon.

    • lewtam
      Participant
      @lewtam
      #12491

      Thank you & look forward to hearing from you.

    • lewtam
      Participant
      @lewtam
      #12500

      Just checking back in with you to see if you’ve been able to isolate the problem. Look forward to hearing back from you. Thanks

    • Christian Freeman
      Participant
      @christianf
      #12502

      Hi Lewtam,

      I see that the AffiliateWP Team had to update the MemberPress integration for Recurring Referrals. This change is probably the cause of the issue with MLM not creating the Indirect Referral for the Recurring Referrals. So now, I’m reviewing their changes and applying them to MLM.

      I’ll follow up soon with a an update/fix.

    • lewtam
      Participant
      @lewtam
      #12503

      Thank you for the update and all the help and support you give us the users of your plugins. Awesome!

    • Christian Freeman
      Participant
      @christianf
      #12523

      Thanks, I’m glad to be of service.

      I sent you a message with a link to download a patched version of MLM 1.1.5, which includes an update for the MemberPress integration.

      Please test it, and let me know how it works for you.

      Also, when you test try it in two ways:

      1) With MLM activated BEFORE Lifetime Commissions

      2) With MLM activated AFTER Lifetime Commissions

      This way, we can completely rule out any issues with the activation order.

    • lewtam
      Participant
      @lewtam
      #12524

      Got it. Thanks. I will test and let you know the results soon.

    • lewtam
      Participant
      @lewtam
      #12549

      Unfortunately, still getting same results.

      But I do notice now that it seems to create an unconverted visit when trial period has ended (view Attachment).

      Any thoughts?

      Attachments:
      You must be logged in to view attached files.
    • Christian Freeman
      Participant
      @christianf
      #12555

      Hmmm, that’s really strange.

      I’m looking into this further now. I think that MLM and Recurring Referrals might be trying to hook in and run at the same time. MLM is designed to create the Indirect Referral immediately after the Direct Referral is created. Because Recurring Referrals is creating the Direct Referral, it’s behaving differently for some reason. I have a few suspicions that I’m going to explore.

      I’ll follow up soon, once I have more information.

      Also, I have a question about this. I know that you were having a similar issue before, but did Indirect Referrals work with Recurring Referrals on your MemberPress setup at all? Meaning, was it working before and stopped working recently? Or did you just notice that it wasn’t working, and may not have been working the whole time?

    • lewtam
      Participant
      @lewtam
      #12557

      Just noticed but I believe it hasn’t been working the whole time.

    • lewtam
      Participant
      @lewtam
      #12572

      Any good news?

    • Christian Freeman
      Participant
      @christianf
      #12576

      I believe I have found the source of the issue. It looks like the MemberPress integration for MLM and AffiliateWP Recurring Referrals are executing at the same time (The same priority level). Now we just have to test it to see if it works when we change the priority.

      Can you run a test of the Recurring Referral, and let me know if it creates the Indirect Referral Commissions for the Recurring Payment on your end?

      Thanks

    • lewtam
      Participant
      @lewtam
      #12580

      Will do. I’ll update you once test is complete.

    • lewtam
      Participant
      @lewtam
      #12586

      Okay after running the above test, so it looks as though the only person that is getting a recurring commissions is Affiliate A.

      for ex.

      When we have this setup

      Affiliate A
      Affiliate B
      Affiliate C

      When a recurring commission is generated from Affiliate A, B, or C’s customers, the only Affiliate that receives a commission is Affiliate A and it is always 20% instead of the settings for the matrix which are
      20% for level 0,
      20% for level 1, and
      40% for level 2.

      so what should happen is when Affiliate C’s customer makes a recurring payment, Affiliate A should get 40%, Affiliate B should get 20%, and Affiliate should get 20%.

      Everything works great on the initial sale, it’s only on the recurring subscription when commissions are not being generated correctly.

      Subscription payments are being generated by memberpress (see attachment) but it does seem the AffiliateWp is taking priority over the MLM integration.

      Hopes this info helps…

      Attachments:
      You must be logged in to view attached files.
    • lewtam
      Participant
      @lewtam
      #12593

      Anything I might be able to do on my end to keep AffiliateWP from taking priority over the MLM plugin?

    • lewtam
      Participant
      @lewtam
      #12616

      Anything good news?

    • Christian Freeman
      Participant
      @christianf
      #12631

      Hey, sorry for the delay.

      I adjusted the priority for all 3 plugins to ensure that they operate in this order:

      1) Recurring Referrals
      2) MLM
      3) AffiliateWP

      Please run another test, and let me know if the Indirect Referrals are created for the Recurring Referrals.

    • lewtam
      Participant
      @lewtam
      #12640

      Any updates to plugins I need to download before changes will be implemented?

    • Christian Freeman
      Participant
      @christianf
      #12646

      I updated the priority for all 3 plugins manually on your site directly.

      If this solves the issue, I will finalize the changes within MLM, and we would need to get the AffiliateWP Team to fix it on their end, buy updating the priority as well.

      But it’s ready to test now.

    • lewtam
      Participant
      @lewtam
      #12648

      Thank you. I had a chance to test but unfortunately getting same results as before.

    • Christian Freeman
      Participant
      @christianf
      #12651

      Hmmmm, maybe the MemberPress integration operates differently for Recurring Referrals, than it does for the other integrations. I’m investigating this further now to see if there’s anything that needs to be changed on the MLM side.

    • lewtam
      Participant
      @lewtam
      #12655

      I know, I didn’t realize this one would be so tuff to pinpoint and fix. Thanks for all your help and hopefully you’ll be able to find the problem and a fix so I can finally get out of your hair.

      Keep me posted.

      Also is anyone else having this particular issue or is it just on my setup?

    • lewtam
      Participant
      @lewtam
      #12731

      Just an update… I think I’m going to try a different plugin because it’s been almost 6 months and I’ve still not been able to get the mlm plugin to work correctly for me and I really need to get this site up and running correctly by the end of this month. Thank you for all your help so far I really was hoping we could get the mlm plugin up and going before now. Thank you again.

Viewing 35 reply threads
  • You must be logged in to reply to this topic.