Home Forums Plugin Support AffiliateWP Affiliate Sign Up Products Buyers don't get registrated as affiliate

12 replies, 3 voices Last updated by Marty 3 months ago
    • Stanlay Forker
      Participant
      @neurosocks
      #10523

      Hi,

      first of all: This is an really cool plugin.. But we’re running into some issues with it. The problem is, that User that buy the Sign Up Product (as Subscription) don’t get registrated as affiliates. Are we missing some options or settings to configure?

      What we have done:

      1. Sign Up Products Settings:
      – Integration: WooCommerce
      – Sync Subscription: checked
      – Owned Product Commissions: uncheckd

      2. We create a simple woocommerce subscription product.
      – Assign Paid Affiliate: checked

      Did we miss something to set up? We are also using your MLM Extension because Customers that buy the SUP Subscription should become a Sub-Affiliate.

      What we try to achive:
      Affiliates (A) should referer new Partners (B) that have to buy the subscription to become an Affiliate. The Master-Affiliate (A) should get a livetime commision for all purchases that are refered by Affiliate B.

      Hopefully you can help us to fix that issue quickly… so many settings 🙂

      Thanks and kind regards

      Stanlay

    • Christian Freeman
      Participant
      @christianf
      #10524

      Hi Stanlay,

      This sounds like it could be an “Order of Activation” issue. If you are using MLM, deactivate MLM, and ensure that Affiliate Sign Up Products is activated before MLM. This will ensure that new affiliates are created after purchasing a Sign Up Product, and it will connect the referring affiliate as the Parent Affiliate.

      Let me know how it works out once you make this change.

    • Stanlay Forker
      Participant
      @neurosocks
      #10525

      Thanks for your reply Christian.. Will give it a try now and let you know if it works or not 😉

    • Stanlay Forker
      Participant
      @neurosocks
      #10526

      So i deactivate the MLM Plugin (set up product still activated) and buy the subscription set up product and still the same issue 🙁 Any other things to check?

    • Christian Freeman
      Participant
      @christianf
      #10533

      Hmmm, I may need to login to your site to see what’s happening here.

      Can you please provide admin-level login credentials? And if so, please be sure to mark your reply as private.

      Also, can you provide the Order Number(s) for your tests with this?

    • Stanlay Forker
      Participant
      @neurosocks
      #10534
      This reply has been marked as private.
    • Stanlay Forker
      Participant
      @neurosocks
      #10536
      This reply has been marked as private.
    • Christian Freeman
      Participant
      @christianf
      #10537

      Thanks for the detailed response.

      I reorganized the logic for the affiliate registration function, as you suggested. However, I made some changes to ensure backwards compatibility with earlier versions of WooCommerce. I’ve sent you a patched version of Affiliate Sign Up Products with this new update via message.

      Please download the file ASAP before the link expires.

      Once you get a chance to download and test this, please, let me know how it works for you.

    • Stanlay Forker
      Participant
      @neurosocks
      #10541

      Thanks for your patch Christian..

      After a short check there is just one little IF-THEN-Condition that needs to be implemented before the new affiliate user is create. You need to check if bought_signup_product is true before creating the user. The Patch released now will still not work and produce the same issue as described. Sorry for that.

      Kind regards
      Stanlay

    • Christian Freeman
      Participant
      @christianf
      #10542

      Hi Stanlay,

      Yes, you are right. I’ve added that conditional statement as you suggested, and it should be working smoothly now. I sent you the updated version of the patch via message again, so let me know how your tests work out, when you get a chance.

      Thanks for the feedback, once again.

      Also, just to let you know, besides the new Per-Product settings for Requiring Product Purchases, I also updated the settings to allow you to enable more than one integration at a time (Multiple options).

      And there’s a separate integration setting for the Subscription Synching feature now, so that you can only link their affiliate account to their subscription based on the chosen integration (Only one choice).

      I should have the update (Version 1.0.2) ready for release by Monday.

    • Stanlay Forker
      Participant
      @neurosocks
      #10551

      Hi Christian,

      thanks for your reply and the fix.. Looks good now. But i already got another issue. Will open an new Topic for that 😉

      Kind regards
      Stanlay

    • Stanlay Forker
      Participant
      @neurosocks
      #10564

      Everything looks good now. Thanks Christian.

    • Marty
      Participant
      @martyhale
      #12488

      I am having this same issue. How can I fix this issue?

Viewing 12 reply threads
  • You must be logged in to reply to this topic.