Home Forums Plugin Support AffiliateWP Affiliate Sign Up Products Affiliate Rate Setting Issue

38 replies, 3 voices Last updated by Christian Freeman 3 years, 1 month ago
    • tankeanhow
      Participant
      @tankeanhow
      #12795

      Hi, we currently facing an issue on our Affiliate Plugin when we try to set Affiliate Rate Type.

      As per shown in Picture 1, we set our Direct Affiliate Rate to Flat Rate (MYR 12). As per shown in Picture 2, we set our InDirect Affiliate Rate to Flate Rate too, MYR 4 for level 1 and MYR 1 for level 2.
      We did a various test and we found that the money for Direct Affiliate didn’t distribute correctly to him as per our setting in Picture 1. In fact, no money is been distributed to our Direct Affiliate at all.
      We also attach along with our settings for Direct Affiliate, please refer Picture 3 for more details.

      We would like to know whether
      1. Is this a setting issue? If yes, please tell us which setting is involved for our Direct Affiliate to get the amount of money as we set.
      2. Is this plugin issue? If yes, would like to ask for your help to correct it.

      Many thanks in advance.

      Attachments:
      You must be logged in to view attached files.
    • Christian Freeman
      Participant
      @christianf
      #12800

      Hello again,

      What are your settings in the MLM tab? I didn’t see them included within the slideshow you provided.

      MLM is what controls and creates the Indirect Referral Commissions that you are speaking of. From what I can see of the Referrals page, it looks like your Indirect Rates for Level 1 might not be configured properly. Once I see it, I’ll be able to tell for sure, and answer your question.

    • tankeanhow
      Participant
      @tankeanhow
      #12816

      Hi, sorry for late reply, here I provide you the settings in MLM tab. It is in the 5th and 6th slide.

    • tankeanhow
      Participant
      @tankeanhow
      #12817

      Hi, my excel exceed 512KB and is unable to be upload on here, please find it in this link:
      https://www.dropbox.com/s/d7bzf9j0mx5q8hn/Affiliate%20setting%20pics.pptx?dl=0

      Many thanks in advance.

    • Christian Freeman
      Participant
      @christianf
      #12828

      Try changing the Indirect Referral Rate Type in the MLM tab (Affiliates > Settings > MLM) to Flat. You have Site Default listed there now.

      After reviewing your Referrals list again, I can see that the Indirect Commissions are working according to your settings. The Parent Affiliate 1 Level above the Direct Referring Affiliate, earned $4 and the Parent 2 Levels above earned $1, which matches your settings.

      Your issue is that the Direct Commission Rate of $10 is generating a $0 commission. That means this issue most likely not being caused by the MLM plugin. Do you have any other AffiliateWP add-on active, and if so, which ones?

      Also, have you tried to test this with MLM deactivated?

    • tankeanhow
      Participant
      @tankeanhow
      #12835

      Hi, I already prepare the print screens of the other activated AffiliateWP add-on, please find it at the link below:
      https://www.dropbox.com/s/02b7lzs6x8acag2/Affiliate%20setting%20pics.pptx?dl=0

    • Christian Freeman
      Participant
      @christianf
      #12836

      Okay, I see that you have the Affiliate Product Rates add-on active. This could be the reason why the commission is $0. Try deactivating this add-on, and test the referral to see if the commission amount is correct now.

      Please, let me know how it works for you.

    • tankeanhow
      Participant
      @tankeanhow
      #13007

      Hi, we just get our website online, would like to ask you why we cant found our Affiliate plugins package on our product tab?

      Attachments:
      You must be logged in to view attached files.
    • Christian Freeman
      Participant
      @christianf
      #13015

      Hi there,

      That’s the Favorite Products section. To access your downloads, you need to visit your account area, and access the Downloads tab:

      propluginmarketplace.com/my-account

    • tankeanhow
      Participant
      @tankeanhow
      #13025

      Hi, we also had ordered a modified version from you right? Would like to know that the files we able to access at https://propluginmarketplace.com/my-account/my-api-downloads/ is already modified or is original version?

      If it is original version, shall we install it first then install the modified version?

      Or shall we install the modified version? If so, we cant find the modified version on it.

      Attachments:
      You must be logged in to view attached files.
    • tankeanhow
      Participant
      @tankeanhow
      #13034

      Hi there, we already install the plugins on our WordPress site and it works fine since we didn’t install ‘Affiliate Product Rates add-on’. We have something else to ask you.

      So, currently, if a registered member buys things with other account’s referral link, the commission can be distributed normally. But, we found an issue that in case of that registered account clear cache and login in an incognito browser, there is no commission distributed to his parent after his purchase. In another word, accounts that made purchase without referral link would not have commission distributed to their parents.

      Would like to ask you that how can we solve this through settings?

    • Christian Freeman
      Participant
      @christianf
      #13037

      Greetings,

      Okay, so it was a conflict with the Product Rates add-on.

      Yes, you should use the AffiliateWP Lifetime Commissions add-on. MLM integrates with it to allow you to sync the Parent Affiliate with the Lifetime Affiliate. This will ensure that any purchases after the initial referred sale, will continue to generate a commission for the all of the Upline Parent Affiliates.

      Once you activate Lifetime Commissions, go to Affiliates > Settings > Integrations, and you’ll see a section for MLM and Lifetime Commissions. Change the Sync Lifetime Affiliate setting to Parent as Lifetime, then save. Then, you can press the Sync ALL button to ensure that all of the existing Parent Affiliates are connected to their Sub Affiliates as Lifetime Affiliate and Customer.

      Regarding the Modified version of MLM, yes, you simply download it from the Licensess tab of your account area. The new Per-Level Product Rates feature is built into version 1.1.5, and all other versions soon to come.

    • tankeanhow
      Participant
      @tankeanhow
      #13039

      Hi there, many thanks in advance for your reply, we also found that Lifetime Commissions add-on can help us in this situation.

      We would like to ask that is there any other alternative instead of using this add-on? For example, you can write a plugin or something equivalent?

      This is because currently, our AffiliateWP’s licence is not able to download the add-on, and upgrading the license is costly.

    • tankeanhow
      Participant
      @tankeanhow
      #13050

      Hi there, we already upgrade our account and downloaded Lifetime Customer plugins, the previous question was solved.

      Currently, we face a new issue:
      Using Microsoft Edge, we did some test to buy Sign-Up Product, the account does become an affiliate (Of Course after we approve him at backend), but his particular purchase of Sign-up Product didn’t generate commissions and distributed. Not only that, this guy, after he became an affiliate, the other purchase he made also did not generate commissions and distribute normally.

      On the other side, the same test (Purchase Sign-up Product generate commissions and distributed correctly, purchase normal product generate commissions and distributed correctly) going well on:
      1. Microsoft Edge ‘Incognito Version’, aka ‘InPrivate window’
      2. Google Chrome
      3. Google Chrome Incognito versions

      We recorded a short video for it to ease the understanding, please view it in the link:

      We would like to know how to solve it, looking for your reply, many thanks.

    • tankeanhow
      Participant
      @tankeanhow
      #13051

      Ahh, Loom’s link failed, here I paste the link again, please remove the semi-colon on front and back:

      ;https://www.loom.com/share/5796611ce67941ffaef12705e412b162;

    • tankeanhow
      Participant
      @tankeanhow
      #13066

      Hi, we would like to ask you about another situation we facing right now:
      In ‘Affiliates > Settings > MLM > Default Affiliates’, we set it to ‘3’. In our understanding, a stranger who visit our site and purchase a Sign-up Product without any referral link, he will become sub-affiliate that belongs affiliate with Affiliate ID ‘3’. But in our test, it didn’t show like that.

      In our test, we set ‘Default Affiliate’ to ‘3’, we use incognito to open our site (without any referral link intact), purchase a Sign-Up Product, and approve the purchase in the backend.
      What we expecting is, this new account will become an affiliate and will be arranged under affiliate with Affiliate ID ‘3’.
      But, our test result didn’t show like that. The new account will be arranged to two test account, Chuah Xuan Hong and TestAccountL, with Affiliate ID of 29 and 12 respectively.

      We would like to know:
      1. Why is this happening
      2. How to solve it
      3. Why this purchasing of Sign-up product without referral link doesn’t generate commissions? (while we already set it in the product page and also other test accounts that purchase Sign-up product with referral link do generate commissions)

      We also made a video to ease the understanding process, please find it in the link below:
      https://www.loom.com/share/87afb678c45e4749ab98ec5e9328993c;

      Looking for your reply, many thanks.

    • Christian Freeman
      Participant
      @christianf
      #13074

      Hi there,

      For some reason, I was not able to play the previous video you posted, but the last one works.

      It looks like the Parent Affiliate may not be listed as the Lifetime Affiliate, which would explain why the referral was not created. What do you have configured for your Lifetime Affiliate Sync settings in Affiliates > Settings > Integrations?

      Also, when you click to Edit the Parent Affiliate of the user who made the test purchase, do you see that user on their Lifetime Customers list?

    • tankeanhow
      Participant
      @tankeanhow
      #13081

      Hi there, let me sum up the situation we facing.

      1. For the first one, when we do test using Microsoft Edge, purchasing Sign-up product with referral links, the generation and distribution of commission was not normal, in fact, it didn’t generate any commission and distribute it.
      On the same time, the generation and distribution of commissions happened normally for
      Microsoft’s Edge Private mode
      Google Chrome
      Google Chrome Incognito mode

      2. For the second one, please refer the uploaded file for the configurations. And, the parent user’s page is showing the test user who made the purchase on their Lifetime Customer’s list.
      The only difference of this and case 1 is that case 1 we are buying with referral links; In case 2, the test user bought it without referral link or whatsoever, the test user open the website directly, purchase the product and we are expecting it will be arranged under the Default Affiliates as per our desire setting but it didn’t.
      And here we found another contradicting issue, even the test user didn’t be arranged as per our setting, the test user is been arranged to other’s parents, it should also generate commissions. This is because for Sign-up Product we also had set some commissions, but the commissions also did not been generated.

      I think that sums up the situation we faced now.

    • Christian Freeman
      Participant
      @christianf
      #13101

      Okay, thanks for clarifying. I understand what you mean now.

      1) Referrals are not created for referred product purchases (Standard Products or Sign Up Products) when using Microsoft Edge. But it is creating the referrals (Direct and Indirect) when you use Edge in Private Mode, Google Chrome, or Google Chrome in Incognito Mode.

      2) When testing affiliate sign up without a referral, the affiliate is not assigned to the Default Parent.

      Can you please provide admin-level login credentials for your site, so that I can investigate this further?

      Also, I reviewed your older screenshots of your active plugins, do you still have the AffiliateWP Allowed Products add-on active? And if so, have you tried testing this with Allowed Products deactivated?

      Regarding the issue with Microsoft Edge. Have you tried deactivating ALL AffiliateWP add-ons, just to test AffiliateWP by itself, and see if the referral links are working at all in Microsoft Edge?

      If not, please run these tests, and let me know the result. And please send me the login info so I can look into it further. You can post it here in a Private Reply, or send via email at: propluginmarketplace[at]gmail[dot]com

    • tankeanhow
      Participant
      @tankeanhow
      #13112
      This reply has been marked as private.
    • tankeanhow
      Participant
      @tankeanhow
      #13142

      Hi Christian, would like to ask you that, for ‘Initial Width’ and ‘Depth’, is there a maximum number?
      Currently, we set ‘Initial Width’ to 9999 and ‘Depth’ to 99, will it cause any problem?

      Attachments:
      You must be logged in to view attached files.
    • Christian Freeman
      Participant
      @christianf
      #13146

      Thanks for providing the login info, I’m still investigating.

      Have you tried testing this with Allowed Products deactivated yet? If not, please deactivate that add-on and test to see if it is causing the issue. I would also recommend deactivating ALL AffiliateWP add-ons and just test with the core AffiliateWP plugin by itself. Then, we’ll be able to see if it’s a plugin conflict, an issue with the core AffiliateWP plugin, or just an issue with one of the add-ons individually.

      Regarding the Initial Width and Depth settings, if you are using a Forced Matrix (Fixed Width), I recommend setting the Initial Width to a lower number in the 2 to 10 range, to allow Spillover.

      If you want to use a UniLevel structure (Unlimited Width), you simply disable Forced Matrix, and set the Initial Width to 0.

      The Depth is required, so it can only have aa minimum value of 1, but there is no maximum amount you can enter. Just keep in mind that each a Depth of 1 will allow every Parent Affiliate to have 1 Level of Sub Affiliates below them. And the number of Levels allowed is the value you enter in the Depth field. So, when you are generating commissions, the system will look through ALL of those levels to see who should receive a commission. If you set the Depth to a super high number like 9999, this could put a strain on your server resources.

      Realistically, there’s no need to set the Depth any higher than 10, because paying commissions on more than 10 Levels for each sale will only lead to paying out more in commissions than you make in the sale.

    • tankeanhow
      Participant
      @tankeanhow
      #13313

      Hi Christian,

      1. Would like to ask you that, from this document — https://propluginmarketplace.com/knowledgebase/docs/configuring-affiliatewp-ranks-settings/
      we learnt that the Rank Plugin can automatically help the user to Advance his Rank as long as he achieved the ‘Requirement’ following the ‘Type’.
      But then, in our site, the plugin was not able to set ”Type’. Would like to ask you why and how should we set it? (You may refer to the picture attached for more details)

      2. On the same time, would like to confirm with you about our Rank Advancement. According to our understanding (we are not able to test it since we cant set the ‘Type’ to ‘Sub-Affiliate’), all affiliate will be assigned as Rank 1.
      Then, after an Affiliate has 2 Sub-Affiliates, the system will AUTOMATICALLY ASSIGN him to rank 2.
      Then, after an Affiliate has 4 Sub-Affiliates, the system will AUTOMATICALLY ASSIGN him to rank 3.
      And the Advancement continue for 8 Sub-Affiliates to Rank 4 and 16 Sub Affiliates to Rank 5.
      Please correct me if my understanding is wrong on this matter.

      These 2 things are the only things we would like to know, 1st thing is about the setting, 2nd is confirmation on Rank Advancement understanding.
      Hope to hear from you soon.

      Attachments:
      You must be logged in to view attached files.
    • tankeanhow
      Participant
      @tankeanhow
      #13315

      Just to make it advance faster, I attach along with the whole page of the Rank setting for you.
      Hope to hear from you soon.

      Attachments:
      You must be logged in to view attached files.
    • tankeanhow
      Participant
      @tankeanhow
      #13325

      Hi Christine,

      Just found out that the ‘Type’ can be set to ‘Sub-Affiliate’ after Performance Plugin been installed. Now we face another question:

      Previously, after a random guy purchase Sign-Up Product, he will automatically become an Affiliate. At the backend, the order status will be ‘Processing’ due to our Payment Gateway automation.

      But now, since we want to integrate with Ranks in our Affiliate System, so the random guy that purchase Sign-Up Product will now become Affiliate with Rank 1.
      What happened is, after he purchases the Sign-Up Product as previous (with the additional condition that assigns the purchaser to Rank 1), the backend’s order status is also ‘Processing’, but then the purchaser is not becoming an Affiliate. He will only become an Affiliate after we complete the order, aka order status changed to ‘Completed’.

      Would like to ask you that is it possible to make it function like the previous version: after he sign, the order status there is ‘Processing’, but he already became an Affiliate with a Rank of 1?

      Attachments:
      You must be logged in to view attached files.
    • tankeanhow
      Participant
      @tankeanhow
      #13330

      Sorry, minor correction for thread #13325, there was a little mistake in Sign-Up Product setting.

      So now, the condition is: with the rank integrating, after he purchases, he became Affiliate.
      With the condition of the backend Order Status ‘Processing’, there was no Rank assigned to the random guy. Only if the backend Order Status changed to ‘Completed’, the random guy will finally be assigned Rank 1.

      Our question still remains the same, after the random guy purchases, is it possible to Assign him Rank 1 automatically with the condition the Order Status still remain ‘Processing’?

      Attachments:
      You must be logged in to view attached files.
    • tankeanhow
      Participant
      @tankeanhow
      #13335

      And also, would like to ask another question besides the previous question (after the random guy purchases, is it possible to Assign him Rank 1 automatically with the condition the Order Status still remain ‘Processing’?):

      The Advancement of Rank is meeting the Requirement set or Exceeding the Requirement?
      Cause we tested a few times, sometimes it is advanced after exceeding the Requirement, sometimes it is advanced after meeting the Requirement.

      Would like to confirm this and Previous Qeustion (after the random guy purchases, is it possible to Assign him Rank 1 automatically with the condition the Order Status still remain ‘Processing’?) from you.

      Many thanks in advance, hope to hear from you soon.

      Attachments:
      You must be logged in to view attached files.
    • tankeanhow
      Participant
      @tankeanhow
      #13380

      Hi Christian,

      Would like to follow up with the status of my issue with you, what is the status?

    • Christian Freeman
      Participant
      @christianf
      #13390

      Hi there,

      I must apologize for the late reply, I didn’t receive the notification for your responses.

      I reviewed your Ranks settings, and I can see that you need to ensure that your Goal-based Ranks are set up in Level Mode. You should set all Ranks that you want to assign automatically based on performance, to Level Mode, and the other Ranks that you manually award, or award via product purchase to Category Mode.

      Ranks are automatically assigned when they meet the performance goals you set.

      You are right, the Rank is only assigned once the order is marked Complete. However, I’m updating the Ranks add-on now to give you the option to assign the rank when the order is in Processing status. I’ve also added this option to the Sign Up Products add-on.

      I’ll send you the updates within the next 2 days.

    • tankeanhow
      Participant
      @tankeanhow
      #13404

      Hi Christian,

      Ok, looking forward on your add-on. Many thanks in advance.

    • tankeanhow
      Participant
      @tankeanhow
      #13437

      Hi Christian,

      Would like to follow up with you regarding the updates, how is it going?

    • tankeanhow
      Participant
      @tankeanhow
      #13447

      Hi Christian,

      Would like to follow up with you regarding the updates, how is it going? Is it any other way to contact you?

    • Christian Freeman
      Participant
      @christianf
      #13498

      Hi there,

      I’m so sorry for getting back to you so late. I had a family emergency and I needed to head out of town suddenly. This threw off my schedule for projects and support.

      Things have been really crazy with COVID-19, but the good news is, everything is fine now, and I’m back in the office getting caught up on everything.

      As of now, the Ranks update is almost ready. It looks like it will be ready within the next 3 days.

      I’ll let you know as soon as it’s ready for release.

      Thanks for your patience.

    • tankeanhow
      Participant
      @tankeanhow
      #13508

      Alright, hope that you can stay healthy and looking to see you soon.

    • tankeanhow
      Participant
      @tankeanhow
      #13524

      Hi Christian,

      Would like to follow up with you regarding the plugin, what is the progress?

    • Christian Freeman
      Participant
      @christianf
      #13556

      I am running my final round of tests now, and making the necessary adjustments. I should have it ready for you to use by Monday (the 4th).

    • tankeanhow
      Participant
      @tankeanhow
      #13575

      Hi Christian,

      It is good to hear from you about that, looking to see your plugin soon.

    • tankeanhow
      Participant
      @tankeanhow
      #13605

      Hi Christian, would like to update with you regarding the plugin, may I know what is it’s current status?

    • Christian Freeman
      Participant
      @christianf
      #13614

      Hi there,

      I sent you a message with the download link for Ranks version 1.0.6.

      https://we.tl/t-zMVPnKS6ni

      Please download this as soon as possible, before the link expires.

      Once you install the update, access the Ranks tab of the AffiliateWP Settings, and enable the “Allow Processing” option. Then, test it out to confirm that it’s working for you, and let me know how it turns out.

Viewing 38 reply threads
  • You must be logged in to reply to this topic.