Home Forums Plugin Support AffiliateWP Invites Ninja Forms integration

3 replies, 2 voices Last updated by  shollycreativeinc 3 days, 21 hours ago
  • shollycreativeinc
    Participant
    @shollycreativeinc
    #10616

    Hello!

    We have your Invite and MLM plugin installed on our website, but we needed a way to add additional form fields to signup. So we installed the official AffiliateWP addon for Ninja Forms.

    What do I have to do to hook the “Invite” Referral code field in Ninja Forms to your MLM system?

    So far, the invite field is not shown, and the affiliate can sign up with no Parent or Direct affiliate association.

    I didn’t see a Referral code mapping on the Affiliate Registration mapping in Ninja Forms, shown here in their documentation
    https://docs.affiliatewp.com/article/809-creating-an-affiliate-registration-form-affiliate-forms-for-ninja-forms

    I’m a developer, so let me know if I need to write a hook, or implement something you give me.

    Thanks so much!

  • shollycreativeinc
    Participant
    @shollycreativeinc
    #10624

    Hi! I just wanted to follow up, and see if I need to make new fields with the PHP approach as opposed to the Ninja Forms way.

    Thanks!

  • Christian Freeman
    Participant
    @christianf
    #10631

    Hi there,

    Sorry for the delay on this. The current version of Invites is only designed to add the Invite Code Field to the Default Affiliate Registration Form. It doesn’t integrate with the Affiliate Forms for Ninja Forms add-on at this time.

    It would require developing a special Ninja Forms integration to create an Invite Code field for Ninja Forms. And it would require a bit more in-depth instructions on how to develop something like this, which is outside of the scope of our support forum.

  • shollycreativeinc
    Participant
    @shollycreativeinc
    #10634

    No problem, it was easier to just add custom fields directly into the standard registration form.

    And a side issue – I haven’t been able to activate our license on the website. I have 0 of 1 activation listed in the Pro Plugin license tab, and it worked in the past. But disabling and re-enabling the plugin loses the registration information.

    I only get an “Invalid Request.” error message.

You must be logged in to reply to this topic.