Home Forums Plugin Support AffiliateWP MLM Bug on Signup

7 replies, 3 voices Last updated by  Christian Freeman 6 months, 4 weeks ago
  • bradleykaufman
    Participant
    @bradleykaufman
    #9513

    Hello there, I recently bought your plugin (which i love so far), But I am having just a few issues with it.

    1.) When I try to signup under one of my test affiliate links (for example:”https://my.smlcoach.com/?ref=1 “), I get an “HTTP ERROR 500” message. I then looked at my Error logs on my host provider and it says:

    [php7:error] [pid 4308] [client 72.222.137.73:38312] PHP Fatal error: Uncaught Error: Call to a member function get_int_product_level_rates() on null in /nas/content/live/smlcoachmember/wp-content/plugins/affiliatewp-multi-level-marketing/integrations/class-base.php:243\nStack trace:\n#0 /nas/content/live/smlcoachmember/wp-content/plugins/affiliatewp-multi-level-marketing/integrations/class-base.php(260): AffiliateWP_MLM_Base->get_product_level_rates(‘1′)\n#1 /nas/content/live/smlcoachmember/wp-content/plugins/affiliatewp-multi-level-marketing/integrations/class-base.php(200): AffiliateWP_MLM_Base->get_parent_rate(’39’, ‘1’, 1, Array)\n#2 /nas/content/live/smlcoachmember/wp-content/plugins/affiliatewp-multi-level-marketing/integrations/class-pmp.php(111): AffiliateWP_MLM_Base->calculate_referral_amount(’39’, ‘0’, ’49’, ‘1’, 1)\n#3 /nas/content/live/smlcoachmember/wp-content/plugins/affiliatewp-multi-level-marketing/integrations/class-pmp.php(63): AffiliateWP_MLM_PMP->process_order(’39’, Array, 1)\n#4 /nas/content/live/smlcoachmember/wp-content/plugins/affiliatewp-multi-level-marketin in /nas/content/live/smlcoachmember/wp-content/plugins/affiliatewp-multi-level-marketing/integrations/class-base.php on line 243, referer: https://my.smlcoach.com/membership-account/membership-checkout/?level=1

    2. Can I have the stats that are displayed converted to be mobile friendly? I posted a few pictures below?

    Attachments:
    You must be logged in to view attached files.
  • Christian Freeman
    Participant
    @christianf
    #9520

    Hi Brad,

    I’m glad you’re enjoying the plugin thus far.

    Regarding the error messages in your 1st point above, I’ve updated the plugin to include a bugfix for this. Please download it from the Downloads tab of your my account page. Once you’ve tested this with the updated version, please let me know how it works for you.

    propluginmarketplace.com/my-account

    About your 2nd point, the Indirect Referrals Table does not currently have the Response feature yet. AffiliateWP just added this recently, but we are planning on adding this feature to our tables soon.

  • bradleykaufman
    Participant
    @bradleykaufman
    #9521
    This reply has been marked as private.
  • bradleykaufman
    Participant
    @bradleykaufman
    #9523
    This reply has been marked as private.
  • nikola.tanchevski@x3m-games.com
    Participant
    @nikola-tanchevskix3m-games-com
    #9528

    I have exact the same issue.
    Can u simply donwload the fix from my Account also??

  • bradleykaufman
    Participant
    @bradleykaufman
    #9534

    Hello?

  • Christian Freeman
    Participant
    @christianf
    #9553

    Hi Brad,

    Sorry for the delay, I didn’t get the notification for you response.

    I’m glad to hear that it’s working smoothly now. Allow me to address your other points below:

    1) When a Parent Affiliate refers a new Sub Affiliate, it’s not supposed to generate a Referral Commission for the new Sub Affiliate by default. If you enable the “Sub Affiliate Referrals” setting, you can set the commission rate to apply to the commission, and award a commission to your affiliates every time they refer a new Sub Affiliate. That referral commission will appear on the Referrals list.

    2) This is actually a bug in the web browser (Google Chrome). We are looking for another solution to this while we wait for the Chrome browser to be updated to fix it.

    3) This looks like it’s related to the integration between AffiliateWP BuddyPress Pro, and the BP Followers plugin. In the Followers section of the BuddyPress Tab (AffiliateWP Settings), which settings do you have enabled?

    @nikola-tanchevskix3m-games-com

    Yes, this fix is working and you can simply download the update from your account page.

  • Christian Freeman
    Participant
    @christianf
    #9554

    @bradleykaufman

    If you do have any of those Follow settings enabled, can you please disable them, and test the affiliate signup process again, and let me know the result?

You must be logged in to reply to this topic.